FOXTEAM UAV CLAN

a Virtual Robotix Network Team

Hi everybody,

I'm currently hooking up my Vrbrain to my new hexa (1.10meter home made CF hexacopter, i'll post the files and solidworks as soon as possible for everyone to be able to make them), and i have two questions:

- First of all, is that normal that when i connect my board to Mission planner (using the usb cable, i need to buy a telemetry kit), it doesn't show up that my GPS is connected (it says GPS: no gps)?

- Secondary, i'm using a 5S lipo on this hexa. I saw in the "Vrbrain bible" that is was the max allowed, so that's perfect, but do you know if the hardware is protected from the high voltage produced when connecting the batteries to the hexa? (i just took the voltage mesurement on my distribution board, and wouldn't like to fry the chip connecting my lipos...

Thanks,

Nick

Views: 466

Reply to This

Replies to This Discussion

Hi Nicolas,

so about the gps .. no gps is not correct what kind of gps are you using and what firmware do you use ? 

Internal or external ? 

The vrbrain support only 5 volt from bec on header , but on point for control vbatt can read untill 6S without problem .. so you need a bec between the lipo battery and vrbrain pin header .. can you explain how you are connecting the battery to vrbrain ? 

best

Roberto 

Hi Roberto,

Concerning the GPS, I'm using the one I bought together with my APM 2.5, the ublox version.. So shouldn't it work? I'm using the external firmware.

Concerning the LIPO, I was talking about the measurement pins. I put a connection to those pins from the distribution board, but when there are sparks when I connect the LIPO, am I sure that the over voltage won't fry the chip?
Shouldn't I put a protection circuit between both?

Thank you,

Nick

I Nicolas , 

the ublox gps work fine with VRBrain , normally no problem ... consider that in rev 3.0 you need to connect gps to telemetry port and vice versa. The external gps firmware is correct revision. It's ok !

About lipo voltage control we don't have problem until 6s lipo ... 

The circuit is protect by a diode.

Best

Roberto 

Hi,

ok to i can't use the GPS port anymore? That stinks..

Ok perfect if the circuit it's protected! i just didn't wanted to burn everything up when connecting my lipo :)

best,

nicola

Hello,

I have a VRBrain 4.5 and a 3DR Ublock GPS,

With Internal GPS firmware, you can use your GPS in the white GPS plug directly on the  VRBrain card. You just have to open a hole in the box to insert your plug.

Marc

Hi,

Ok that's the firmware I'm gonna use so because I already made the hole in the case :)

Thank you very much,

Nicolas

I just bought a VRbrain and compass/GPS (it came with the 3DR unit which include both GPS and compass)

Now i tried to find how to connect this 3dr unit along with 3dr 433 telemetry.

It is not clear how to connect?

Tried to find a complete pinout for the small connectors thats on the vbrain board, is there a picture which explain ALL pins not only the input/output pins?

I worked out where to connect the GPS on the sidepins marked "MAVLINK" on the pictures avalible, but where to connect the 3dr telemetry when the "MAVLINK" is occupied with the GPS?

Thank/Goran

Hello,

There is some info there:

http://vrbrain.wordpress.com/assembly-instructions/

I have GPS (without compass) plugged on the White GPS plug of the board (internal gps). For the compass, you should look in the forum and news to find the wiring diagram. 

For Telemetry, Use RX and TX right upper pins and use Lower for Ground and Middle for +5v.

Marc

I have it work now, thanks

Hi Goran,

If you Want, you can hook up the external compass on pin 7and 8 :)

Nick

RSS

Events

© 2019   Created by Roberto Navoni.   Powered by

Badges  |  Report an Issue  |  Terms of Service